Jump to content
Zr2USA.com
Sign in to follow this  
Da Snake

2002 Blazer to 2002 S10 ZR2 Transmission Swap

Recommended Posts

Like the Topic states, I'm wondering if the 2002 Blazer Transmission is a direct swap into my 2002 S10 ZR2. The Blazer only has 85,000 kms on the clock, while my ZR2 is pushing 328,000 kms and is starting to slip a little. While I know that they're both 4L60E's, but are the really the same? The owner is looking for $350 and that's a whole bunch less than rebuilding the Z's tranny.

 

Anyone have an idea on this?

 

Cheers

 

John

Share this post


Link to post
Share on other sites

You didn't mention if the donor is 4X4, and if both have the same pushbutton configuration (autotrak on the blazer?) if not you may need to take some parts off the Z tranny (bell housing, tail?) to make it work. So it may not be plug and play but it should fit. Don't forget these added costs and if your not doing the swap yourself there will be some heavy (maybe more than the whole donor) labor costs. I'm looking at this myself so I've been checking into it vs 1800-2500 for a rebuilt unit or having my own rebuilt with some improved parts like corvette servos.

Share this post


Link to post
Share on other sites

yes, will be a direct swap if it is a 4wd transmission. a 2wd will have a different tailshaft since it doesn't bolt to the t-case.

the style of tcase does not matter, both interface the same. bellhousings are all the same.

price seems high compared to what I see around here.

I sold a 4L60e (2wd) for $50 since noone wanted it for $80

Edited by greencactus3

Share this post


Link to post
Share on other sites

Sorry gentlemen I should have mentioned that the Blazer is 4X4, and has the identical 3 pushbutton set up as my Z.

 

Thank you all for your assistance. I really appreciate the help.

 

Cheers.

 

John

Share this post


Link to post
Share on other sites

***Update***

 

I decided to have my 4L60E rebuild as apposed to doing a swap. I also had the torque converter rebuild. The outcome was not as predicted. Something is still slipping and I have no clue what it could be. Transfer Case, or is there something in the rear end that will allow things to slip?

  When I push the gas pedal down it no longer launches as it once did. Again it feels like it's slipping. I'm at a loss here.:wtf:

 

Has anyone else has this occur? :pissed:

Share this post


Link to post
Share on other sites

are you sure it is starting in first gear? my truck had a computer problem and I lost first and I think 3rd? gear. The computer wasn't telling the transmission to activate the solenoid for first gear.

Share this post


Link to post
Share on other sites

It might be that the different feel launching from stop lights or other places is not due to a driveline problem.

With 328,000-km in the engine, it's very possible there's a problem which is causing poor or slow throttle response.

Share this post


Link to post
Share on other sites

They wouldn't use a different converter between S10 and Blazer, would they?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.