swillbee

Subscribed ZR2 Owner
  • Content count

    1,094
  • Joined

  • Last visited

  • Days Won

    1

About swillbee

  • Birthday 11/23/1960

Contact Methods

  • Website URL
    http://
  • ICQ
    0

Profile Information

  • Gender
    Male
  • Location
    Kansas City
  • Interests
    Guns, movies, fine handcrafted ales & of course my Zr2.

Previous Fields

  • Name:
    Chris W. Thornton
  • Country
    United States
  • State or Providence:
    Kansas
  • ZR2 Year:
    2003
  • ZR2 Color:
    White
  • ZR2 Model:
    Chevy S10
  1. and there's no rust either....Dammit!! Welcome aboard.
  2. I put in a pair of Timkin's about 7 years ago to fix a wheel speed sensor/ABS issue I was having, but last spring the drivers side went south on me. They just don't make anything like they used to. Or you can go with a AC Delco part that is a reman.
  3. I got some new Westin step bars for Xmas and while removing the old rusted up ones, the 4 cab bushings I was working with practically disintegrated in my hands. Looks like I'll be shopping for 8 of those cab bushings. My question is this: Did anyone have issues with brake lines, wiring, etc. when you jacked up the cab? I know it only needs to go up a couple of inches to get the upper bushings out but I'm still a bit paranoid about doing this since I already snapped off a bushing bolt that was rusted in place and until I get it out the drivers side step bar can't be put in. I haven't remove the upper bushing yet to see if have any threads left on it to grab or weld a nut on it. I've sprayed the shit out of it with PB Blaster I'm hoping there's some threads there for me.
  4. I'm not in CT but I think any reputable welder can make the repairs and reinforce it where needed. May need to have a body shop check the frame for straightness after it's done.
  5. I'LL BE TALKING TO SANTA THIS YEAR!!
  6. I have only the red lens, if you find the assembly without the lens then keep me in mind.
  7. PROBABLY STOLEN FROM SOMEWHERE IN THE U.S.
  8. WELCOME FROM KANSAS!
  9. SAME, EXACT PROBLEM. THE VACUUM ACTUATORS IN OUR TRUCKS ARE JUNK. I'M GUESSING ITS THE MODE CONTROL ACTUATOR IN MINE, BUT MY TRUCK IS A D.D. AND CAN'T AFFORD THE DOWN TIME TO TEAR INTO THE DASH TO REPLACE IT.
  10. ENCODER MOTOR? THERE ARE 4 HALL EFFECT SENSORS IN THE ENCODER MOTOR, IF ANY ONE OF THOSE GOES WHACKY, THEN ANY NUMBER OF WIERD ISSUES CAN OCCUR. I CHECKED MINE THIS SUMMER, AND IT JUST "CLICKS" ONCE WHEN I PUSH THE 4HI SWITCH AND IT DOES NOT ENGAGE THE FRONT DIFF. GUESS I'LL BE CHANGING OUT THE ENCODER MOTOR THIS FALL.
  11. WELCOME ABOARD CAPTAIN! YOU'LL FIND A BUNCH OF "BEEN THERE, DONE THAT" MEMBERS ON THIS SITE THAT CAN CLEAR UP JUST ABOUT ANY QUESTION YOU MAY HAVE ABOUT THE ZR2.
  12. Fine job, thanks for the pics.
  13. Gany pic's of it in the truck??
  14. I do like your set up Derek. I'll poke around the headlight harness tonight, thanks.